TP-Link JetStream 8-Port Gigabit Smart Switch with 4-Port PoE+
Buy Online
At a Glance
Key highlights and verified hardware specifications
Andote Analysis
All parameters are evaluated as per the price. Our algorithm calculates each hardware specification's relative efficiency against peer products in the category based on its selling price, giving you an objective measure of value per pound. User ratings are not included in this calculation.
Price History
Lightning deals from Amazon. Guaranteed discounts!
Top alternatives to consider
View all alternativesThese recommendations include other storage sizes, colors, and closely matched variants of this product so you can easily compare pricing across available options.






Products you might be interested in
View more in routers switches wi fiTrending items in the same category to help you discover popular alternatives other shoppers are considering.






User Reviews & Community Discussions
About TP-Link JetStream 8-Port Gigabit Smart Switch with 4-Port PoE+
8× Gigabit ports (4× 802.3at/af-compliant PoE+ ports). 62 W total PoE budget with up to 30 W PoE output per port*. Centralized cloud management via the web or the Omada app†. Standalone management via web, CLI, SNMP, and RMON. Static Routing helps route internal traffic for higher efficiency. VLAN, ACL, QoS, and IGMP Snooping. Fanless design for silent operation. Durable metal casing and desktop/wall mounting design. TP-Link’s brand new Omada smart switches provide huge upgrade comparing with previous versions. The switches can be managed by Omada SDN Controller, which provides professional and reliable one-step solutions. Integrated L2 and L2+ features such as 802.1Q VLAN, QoS, IGMP Snooping and static routing provide cost-effective networking solutions for small and medium-sized businesses without sacrificing enhanced usability and strong performance.. Management features. Switch type. Managed. Switch layer. L2/L2+. Quality of Service (QoS) support. Yes. Web-based management. Yes. ARP inspection. Yes. System event log. Yes. MIB support. MIB II (RFC1213) Bridge MIB (RFC1493) P/Q-Bridge MIB (RFC2674) Radius Accounting Client MIB (RFC2620) Radius Authentication Client MIB (RFC2618) Remote Ping, Traceroute MIB (RFC2925) Support TP-Link private MIBs RMON MIB(RFC1757, rmon 1,2,3,9). Ports & interfaces. Basic switching RJ-45 Ethernet ports quantity. 8. Basic switching RJ-45 Ethernet ports type. Gigabit Ethernet (10/100/1000). Network. Networking standards. IEEE 802.1D, IEEE 802.1Q, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3af, IEEE 802.3at, IEEE 802.3i, IEEE 802.3u, IEEE 802.3x. 10G support. No. Port mirroring. Yes. Rate limiting. Yes. Spanning tree protocol. Yes. Broadcast storm control. Yes. Link aggregation. Yes. Auto-negotiation. Yes. Auto MDI/MDI-X. Yes. Flow control support. Yes. VLAN support. Yes. Number of VLANs. 4094. Data transmission. MAC address table. 8000 entries. Switching capacity. 16 Gbit/s. Forwarding rate. 11.9 Mpps. Number of queues. 8. Jumbo frames support. Yes. Jumbo frames. 9000. Packet buffer memory. 4.1 MB. Security. DHCP features. DHCP client, DHCP relay, DHCP snooping, DHCPv6 server, DHCPv6 snooping. IGMP snooping. Yes. Authentication type. RADIUS. Authentication. MAC-based authentication, Web-based authentication. Security algorithms. 802.1x RADIUS. MAC address filtering. Yes. Multicast features. Multicast support. Yes. Protocols. Management protocols. SNMPv1/v2c/v3. IPv4 & IPv6 features. IPv6 Telnet, IPv6 ping, IPv6 tracert. Design. Rack mounting. Yes. Product colour. Black. LED indicators. Yes. Performance. Fanless. Yes. Power. Power supply included. Yes. Power consumption (max). 77.3 W. Power over Ethernet (PoE). Power over Ethernet (PoE). Yes. Power over Ethernet plus (PoE+) ports quantity. 4. Operational conditions. Operating temperature (T-T). 0 - 40 °C. Storage temperature (T-T). -40 - 70 °C. Operating relative humidity (H-H). 10 - 90%. Storage relative humidity (H-H). 5 - 90%. Heat dissipation. 263.6 BTU/h. Weight & dimensions. Width. 209 mm. Depth. 126 mm. Height. 26 mm. Packaging content. Manual. Yes. Packaging data. Package type. Box. General. Product family. Omada. Certificates. Certification. CE, FCC, RoHS. leaflet. manual pdf. Regulatory Compliance. Installation Guide. Wall Mounting Guide. Omada Cloud SDN—The Smarter Cloud Solution for Business Networking





